NVIDIA and AMD driver updates

Prev13

Comments

  • Um... considering the problems reported by users on 368.22 I think I'll pass.
  • I took the leap, got slightly better fps ~2-3 fps on hyper with a 980Ti 6 GB running 1080p. It did run fine before the update so it's up to you if you want to update.
  • fraka
    54 posts
    edited June 2016
    same for me, i've seen a little improvement after updating for the last Nvidia driver (GTX 970)
  • Does this new driver update fix the massive lag and stuttering during cutscenes? Gonna have to test this when I get out of work.
  • Does this new driver update fix the massive lag and stuttering during cutscenes? Gonna have to test this when I get out of work.

    Nope, sadly it does not.
  • Alcatrax wrote: »
    Does this new driver update fix the massive lag and stuttering during cutscenes? Gonna have to test this when I get out of work.

    Nope, sadly it does not.

    Greatttttttt......
  • biggest problem right now is the textures

    sometimes they don't load... sometimes it takes 5 seconds of looking at it up close.

    I've also been monitoring my VRAM usage and it isn't fully utilized. This is with the vram restriction setting unchecked AND checked. both ways it still doesn't use all available vram.
  • Andross wrote: »
    biggest problem right now is the textures

    sometimes they don't load... sometimes it takes 5 seconds of looking at it up close.

    I've also been monitoring my VRAM usage and it isn't fully utilized. This is with the vram restriction setting unchecked AND checked. both ways it still doesn't use all available vram.

    If you didn't restart in between toggling the VRAM Usage box, it may not take effect.
  • haha at least you guys can play it at all. all i get is a black screen when i launch the game
  • Vincent, can you comment on whether the team plans on adding crossfire support?
  • haha at least you guys can play it at all. all i get is a black screen when i launch the game

    Well what is your specs on your computer?
  • I'm kinda hoping DICE will fix the issue with the reflections quality. It's seriously awful that I can't set the reflections to higher quality other than low. It just doesn't look all that good. Plus, during the beta, I could set it higher without an issue. Seems like Frostbite isn't as stable as I thought.
  • Alcatrax wrote: »
    I'm kinda hoping DICE will fix the issue with the reflections quality. It's seriously awful that I can't set the reflections to higher quality other than low. It just doesn't look all that good. Plus, during the beta, I could set it higher without an issue. Seems like Frostbite isn't as stable as I thought.

    The DirectX errors seem to be very individual. Mine appears at once if I increase the textures setting. If I've got it on low I'm even able to play with some of the settings on ultra without the client crashing.

    I've found that having an FPS cap helps stabilize the game. It doesn't crash as much for me when I've set the cap to 40. I'm using Riva Tuner.


  • Znomito
    2 posts
    edited June 2016
    To bad the drivers doesn't work for older cards... I have HD radeon 6950.
    And deleting PROF_SAVE_profile does nothing too... hotfix plez
  • I would also like a workaround for older cards (HD5750 here). The game ran perfectly smooth with the old drivers, but now it won't start, because it requires the newest AMD driver (which does not support my card anymore).
  • I'm having the same problem Really frustrating to be locked out of my game half way through the story.
  • I can't open my game because I have radeon hd 6870 and it don't support those drivers the game needs, pls frostbite fix this ****. I don't have money to waste on no working games.... (sorry for bad english) (I know there's someone of the frostbites employees reading this, so please be nice to me and the other players who can't update those **** drivers and fix that issue)
  • Vincent0K wrote: »

    I can't update to these drivers, is there any way to play this game with older drivers? my graphic card is amd radeon hd 6870 1gb. my driver is 15.301.1901, please help me =)
  • I’ve waited so long to play Mirror’s Edge Catalyst, the day it came out I bought it on Origin, installed and it launched just fine. I had to play on low settings but it was still a great experience and I was enjoying it so **** much. Then some days later this update happened and suddenly I couldn’t play anymore. Senseless game update was senseless. It was working just fine with the old drivers, why change it? I spent 60 euros on MEC and now I can’t play it because the drivers won’t update to the version they ask for. Thanks a lot, whoever came up with this.
    I have AMD Radeon R9 M200X series and the latest driver version available from AMD is 16.15.2211 while the game now asks for a minimum of 16.20.1025. So now what? No recent drivers, no game?
    Please come up with a solution.
  • Eeveel25 wrote: »
    I’ve waited so long to play Mirror’s Edge Catalyst, the day it came out I bought it on Origin, installed and it launched just fine. I had to play on low settings but it was still a great experience and I was enjoying it so **** much. Then some days later this update happened and suddenly I couldn’t play anymore. Senseless game update was senseless. It was working just fine with the old drivers, why change it? I spent 60 euros on MEC and now I can’t play it because the drivers won’t update to the version they ask for. Thanks a lot, whoever came up with this.
    I have AMD Radeon R9 M200X series and the latest driver version available from AMD is 16.15.2211 while the game now asks for a minimum of 16.20.1025. So now what? No recent drivers, no game?
    Please come up with a solution.

    I have same problem :( Fix that please.
  • NightRunner
    21 posts
    edited June 2016
    Yeah. I really have to ask what the necessity is for a minimum driver version.

    Yes, my AMD graphics card is not officially supported (HD 6850), but, I could run the game, and run it quite well, albeit at minimum settings. Right now, the minimum driver version is making me unable to play the game, since my card is now a legacy card, meaning no more driver updates are released for them.

    I can understand some cards not being supported, but, being completely locked out from the game goes a bit too far...
  • I would suggest people having trouble with driver either asking for refunding or try call EA support to get some answers...
  • Zefnoly wrote: »
    I would suggest people having trouble with driver either asking for refunding or try call EA support to get some answers...

    I doubt it will help in any way, since it's hardcoded into the game.
    We need to find the .dll to rename like we can on nvidia installations to bypass the driver version check.

    "you need driver 368.39 to run!"
    *runs game on 361.75 and gets no issue at all*
    yeah, really need for latest version...

    Who thought fake driver version requirements were a good idea?
  • I have a brand new iMac that was running the game fine under bootcamp with the latest drivers. After the update I am locked out of the game. THERE ARE NO NEWER DRIVERS FOR BOOTCAMP. Let me play the game! I really like it, but this is frustrating!
  • A notification saying that your driver is not updated, and that unstable performance can be expected is more than enough. Then let the users pick accept or decline to these terms to run the game...
  • I HAVE A PROBLEM!! WHO CAN HELP ME?

    I have the game.. and I already started playing it. Now when i want to run the game I get a message saying that I need to update my driver to 16.20.1025 and that I have currently 15.20.1062.. Now I downloaded Crimson 16.6.1 (the link above) but i still get the same error/message? How can i fix this? because I am at that point that i want to cry my eyes out!! And i am not that handy with computers!!!
  • Bouchra, if your graphics card is older than the HD 7000 series, you're out of luck. You cannot fix it. This is what everyone above you is complaining about.
  • zeraoo98
    130 posts
    edited June 2016
    I CAN'T STAND THIS ANYMORE PEOPLE

    THIS DRIVER NONSENSE HAS NOTHING TO DO WITH DICE/EA/DEVS/THIS FORUM

    THE AMD FORUMS ARE LOCATED HERE


    https://community.amd.com/community/support-forums/drivers-software
    https://community.amd.com/community/support-forums/drivers-software
    https://community.amd.com/community/support-forums/drivers-software
    https://community.amd.com/community/support-forums/drivers-software
    https://community.amd.com/community/support-forums/drivers-software

    It's AMD guys that lock you out of the game, not ME team. You are BELOW MINIMUM REQUIREMENTS that were written on the box/page when you bought the game. Nothing's gonna change with this endless complaints. Consider buying something else than AMD next time. Some other manufacturer that actually support their GPUs. Yes, I'm talking about team green.

    Thank you.

    PS. Check minimal requirements next time, k?

    PS2. For those of you who didn't catch the beat. Cards you own are too old according to AMD, so they figured "hey you know what, forget about those once, don't release any updates anymore, let them go out and buy newer cards instead." So you won't be able to download the latest and greatest, because the card is past it's "best before" date.
    f81c33dd99.png
  • zeraoo98 wrote: »
    I CAN'T STAND THIS ANYMORE PEOPLE

    THIS DRIVER NONSENSE HAS NOTHING TO DO WITH DICE/EA/DEVS/THIS FORUM

    THE AMD FORUMS ARE LOCATED HERE


    https://community.amd.com/community/support-forums/drivers-software
    https://community.amd.com/community/support-forums/drivers-software
    https://community.amd.com/community/support-forums/drivers-software
    https://community.amd.com/community/support-forums/drivers-software
    https://community.amd.com/community/support-forums/drivers-software

    It's AMD guys that lock you out of the game, not ME team. You are BELOW MINIMUM REQUIREMENTS that were written on the box/page when you bought the game. Nothing's gonna change with this endless complaints. Consider buying something else than AMD next time. Some other manufacturer that actually support their GPUs. Yes, I'm talking about team green.

    Thank you.

    PS. Check minimal requirements next time, k?

    PS2. For those of you who didn't catch the beat. Cards you own are too old according to AMD, so they figured "hey you know what, forget about those once, don't release any updates anymore, let them go out and buy newer cards instead." So you won't be able to download the latest and greatest, because the card is past it's "best before" date.

    Lol, are you for real?

    The game forces driver versions with no real need.

    Why should I be forced to update to latest drivers when the version I'm using works just fine?
  • ninemil
    218 posts
    edited June 2016
    KSA wrote: »
    Lol, are you for real?
    Yes, he's for real. He's also completely right. Just because you hadn't encountered something serious, doesn't mean it wouldn't have happened eventually. Driver locks are rare used, and generally only in the case where something in the current build has been seen to compromise hardware, or the stability of the OS.

    Regardless, that doesn't change the fact that it's AMD who shafted you, not DICE. You're throwing your pitchfork at the wrong people.

    3baf5502-dd13-441d-8dd6-3b5afbbe0347.jpg
    12% now, and dropping. I wonder why?
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!